Je ne sais pas comment le dire, mais je suis particulièrement énervé. Je viens de passer des heures à tenter de remplir un formulaire sur https://pastel.diplomatie.gouv.fr/Dali/index2.html. Ils disent que les formulaires sont particulièrement optimisés pour Internet Explorer 6 et au delà, Safari 3 et firefox 3. Cool me dis-je, moi qui suis sous linux et qui ai un firefox 3.x (je ne me souviens plus de la version car présentement je suis sous windows sur l'ordinateur de ma copine !) ç va marcher au poil. .... Que neni ! Une fois que tout est rempli, il ne veux pas passer à la dernière étape qui est celle de la confirmation !

Je tente donc sous windows (avec firefox) le symptôme est le même !! (Faudra me dire si c'est pareil avec Safari ?). Donc, je passe sous internet Explorer (oulà là quelle interface bordélique !) en version x.x (je n'ai pas trouvé où est le dialogue pour afficher une boite "a propos" digne de ce nom ... comment ils font pour remonter les bugs ??). Après avoir rempli à nouveau tous les champs, je tombe sur la page de confirmation (comme si de rien n'était !) ...

Et quoi, si je n'avais pas eu une copine avec un ordinateur sous windows avec internet explorer d'installé je n'aurais pas pu profiter de la souplesse d'une demande d'extrait d'acte de naissance par internet ? C'est vraiment trop fort ! Et dire que ça fait plus de 10 ans qu'on se bat pour les standards ouverts, les protocoles ouverts et les logiciels libres qui les respectent.... Tout ça pour en arriver à cette constatation en 2010 ! Je suis fatigué de la médiocrité (personne n'aura testé avec firefox ou quoi ?) et des mauvaises prestations ! Quand est-ce que nos administrations prendront conscience que l'informatique doit leur appartenir ? Qu'à ce titre, la compétence doit être interne ?

Vraiment, hallucine de voir encore ce genre de choses en 2010 !